Depict - Degraded performance: merchant portal pages loading slowly – Incident details

Degraded performance: merchant portal pages loading slowly

Resolved
Degraded performance
Started 23 days agoLasted about 1 hour

Affected

Portal (Supergrid merchandising app)

Degraded performance from 6:04 PM to 7:12 PM

Updates
  • Resolved
    UTC
    Resolved

    From 20:04 to 21:12 CEST a subset of merchant-portal page loads and collection-data requests were extremely slow (30 seconds to several minutes in the worst window 20:38–20:48 CEST); requests completed without errors and no data was lost. Root cause: a throughput ceiling in the network path between our edge platform and database, reached during an unusually large ingestion traffic surge. We deployed a transport-protocol fix at 21:09 CEST and latency returned to normal within three minutes. Follow-up capacity and alerting improvements are in progress.

  • Monitoring
    UTC
    Monitoring

    We deployed a transport-protocol fix and are monitoring latency.

  • Identified
    UTC
    Identified

    We have identified a throughput ceiling in the network path between our edge platform and database as the cause of the slow page loads.

  • Investigating
    UTC
    Investigating

    We are investigating reports of slow page loads in the merchant portal.